【tech】NEC IX2015、IX2105の初期化手順メモ



公開:2020/04/28
更新:2020/04/28

自宅で使っていたIX2015とIX2105をヤフオクで処分したので、発送前の初期化をしたメモです。

NECのIXもciscoのterminal length 0 (ter len 0)がそのまま入力できるし、screen-length disableというコマンドでも同じ動作させることができるんですね!

IX2105の初期化


・ログインする

・configモードへ移行
enable-config

・スタートアップconfigの削除
erase startup-config
→yes

・configモードから抜ける
exit

・configの初期化
default-console command-line

・リロード
reload
→yes

ログ





Router# enable-config
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)# erase startup-config
Are you sure you want to erase the startup-configuration? (Yes or [No]): yes
Router(config)# exit
Router# default-console command-line
% You must RELOAD the router for this configuration to take effect.
Router# reload
% Warning: current running-configuration is not saved yet.
Notice: The router will be RELOADED. This is to ensure that
the peripheral devices are properly initialized.
Are you sure you want to reload the router? (Yes or [No]): yes

NEC Bootstrap Software
Copyright (c) NEC Corporation 2001-2011. All rights reserved.

%BOOT-INFO: Trying flash load, exec-image [ix2105-ms-8.7.22.ldc].
Loading: ############################################################### [OK]

Starting at 0x20000

Configuring router subsystems (before IDB proc): done.
Constructing IDB(Interface Database): done.
Configuring router subsystems (after IDB proc): done.
Initializing router subsystems: done.
Starting router subsystems: done.

All router subsystems coming up.

NEC Portable Internetwork Core Operating System Software
Copyright Notices:
Copyright (c) NEC Corporation 2001-2011. All rights reserved.
Copyright (c) 1985-1998 OpenROUTE Networks, Inc.
Copyright (c) 1984-1987, 1989 J. Noel Chiappa.
Router#

IX2015の初期化





コンソールケーブルで接続後、電源を入れます。
起動中のロード画面中の「###」が増えていくタイミングで、「ctrl」+「c」で、bootモードに入ります。
(ログに記載しています。)

※bootモードでは「?」でヘルプが出せます。

・スタートアップコンフィグの削除
cc
→y

・デフォルトコンフィグの削除
dc
→y

・初期化してboot

ログ





stic Software
Copyright (c) 2001-2008 NEC Infrontia All Rights Reserved.

%DIAG-INFO: Starting System POST(Power On Self Test)

DRAM TEST 1: Pass
DRAM TEST 2: Pass
NVRAM TEST: Pass
CPU TEST: Pass
PLD TEST: Pass
LAN1(FE0/0) TEST: Pass
LAN2(FE0/1) TEST: Pass
SECURITY TEST: Pass
VOLTAGE STATUS: 3.251V Pass
TEMPERATURE STATUS: +24.0degC Pass

NEC Bootstrap Software
Copyright (c) 2001-2008 NEC Infrontia All Rights Reserved.

%BOOT-INFO: No boot records found, attempting flash load.
%BOOT-INFO: Trying flash load, exec-image [ix2010-ms-8.3.49.ldc].
Loading: ################### ★★★ここで「ctrl」+「c」
NEC Bootstrap Software, Version 22.34
Copyright (c) 2001-2008 NEC Infrontia All Rights Reserved.



boot> cc
Enter "Y" to clear startup configuration: y
% Startup configuration is cleared.

NEC Bootstrap Software, Version 22.34
Copyright (c) 2001-2008 NEC Infrontia All Rights Reserved.
boot> dc
Enter "Y" to clear default configuration: y
% Default configuration is cleared.

NEC Bootstrap Software, Version 22.34
Copyright (c) 2001-2008 NEC Infrontia All Rights Reserved.
boot>
boot> b



NEC Bootstrap Software
Copyright (c) 2001-2008 NEC Infrontia All Rights Reserved.

%BOOT-INFO: No boot records found, attempting flash load.
%BOOT-INFO: Trying flash load, exec-image [ix2010-ms-8.3.49.ldc].
Loading: ######################################################## [OK]

NEC Diagnostic Software
Copyright (c) 2001-2008 NEC Infrontia All Rights Reserved.

%DIAG-INFO: Starting Interface Unit POST(Power On Self Test)

%DIAG-INFO: Interface unit is 4FESW-BRI
HUB(SW)1-4 TEST: Pass
BRI TEST: Pass

Starting at 0x20000

Configuring router subsystems (before IDB proc): done.
Constructing IDB(Interface Database): done.
Configuring router subsystems (after IDB proc): done.
Initializing router subsystems: done.
Starting router subsystems: done.

All router subsystems coming up.

NEC Portable Internetwork Core Operating System Software
Copyright Notices:
Copyright (c) 2001-2008 NEC Infrontia All Rights Reserved.
Copyright (c) 1985-1998 OpenROUTE Networks, Inc.
Copyright (c) 1984-1987, 1989 J. Noel Chiappa.
Router#

久しぶりにみてみると、モバイルバッテリーもずいぶん安くなってるんですね!

皆さん既にやってると思いますが、 AmazonPrimeだとAmazon Music Unlimitedが月額780円でできるんですね!
最近知ってapple musicから乗り換えました。(200円ですが安い方がいいに越したことはないです笑)

下のPythonの本は kindle unlimitedで無料で読めますのでお勧めです!(30日無料期間に読んで解約もアリだと思います。笑)



【tech】IX2105でtelnetができないときのメモNEC UNIVERGE IX2105



ヤフオクで買った中古のIX2015で遊んでいたお話は何度か書きましたが、さすがに100Mポートに限界を感じ、ヤフオクなどでRTX1200などが安く買えないか見ていたのですが、中古のIX2105が4000円位まで下がってきているという情報を得たので、さっそく買いました!笑

なんと、YAMAHAのRTX1200(のOEM品のNTT BIZ BOX N1200)と、YAMAHAのRTX810!(のOEM品と笑)NECのUNIVERGE IX2105を4台!しめて送料もいれて総額20000円です!安く買えてますよね~

この夏はこれらのNW機器で遊び倒します!笑

私が使っているPC(のメモリが8GBの物)です!
私はこのPCのメモリを現在では32GBにアップグレードして使っています!笑
安くなりましたよねメモリ。SSDも安くなってるので買い換えたいです!笑

本題

さっそく、NEC UNIVERGE IX2105で遊ぼうと思ったのですが、consoleで接続して、IPアドレスを設定して、pingは飛ぶけどtelnetができない・・・

簡単に調べてみたのですが、IX2105はix2015とはちがってtelnetやsshをenableしてあげないとだめなんですね!


コマンド

・telnetを使用できるようにする
telnet-server ip enable

・SSHを使用できるようにする
ssh-server ip enable

以下、ログです。


Router#
Router# configure
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#
Router(config)# telnet-server ip enable
Router(config)#
Router(config)# ssh-server ip enable
Router(config)#
Router(config)#


設定保存のwrite memoryをお忘れなく!

telnetはすぐできたのですが、SSHだとユーザをつくって、パスワードを設定してあげないとダメなんですね、たしかに・・・納得です!
ユーザ作成などはまた調べて更新しておきます!!

これでIX2105とRTX1200とRTX810でNWをつくってZabbixから監視したりAnsibleで設定変更加えてみたりできると思うと、とても楽しみです!

こちらもぜひみてみてください!

・Zabbix4.2をCentOS7上に構築する
・Zabbix4.2からNW機器(VyOS)のトラフィック監視する


楽天トラベル

下のRedmineとZabbixの本は kindle unlimitedで無料で読めますのでお勧めです!(30日無料期間に読んで解約もアリだと思います。笑)



【tech】ヤフオクの中古で揃えた自宅サーバ・ルータ検証環境



全部中古で買いそろえました。笑
2019年になっても、これからサーバやネットワークのお勉強を始める初心者の方にはおすすめのセットなのではないでしょうか?何より、わたしと同じ環境に整えてもらえれば私もできるかぎりサポート致しますし。笑

このセットであれば、サーバ(ワークステーション)・ルータなど一式で5万円位でそろってしまうので(クラウドなどでお勉強を始める事も可能ですが)やっぱり実物をみてイメージしながら理解するのが簡単だと思います!

ワークステーションは45000円位で、基本的にはCentOS7を使用して、KVMや時々別のHDDのESXiをインストールして勉強しています!IX2015は5台で送料込み5000円位、RTX1100は送料込みで6000円位でした。全部ヤフオクです。笑 本当はRTX1200が欲しかったのですが、RTXでLAG(リンクアグリゲーション)を組んでみたかったので、RTX1200だと2台買うと、まだ1台当たり10000円位なので、合計20000円かかってしまうので諦めました。泣


憧れの1Gポート 笑

今使用しているのは下記の通りで・・

・WS(ワークステーション)
HP Z800
CPU Intel Xeon x5650 (6c12t) x2
RAM 8GB x6 4GB x3 合計56GB
HDD 500GB x4

・NW機器(ルータ/スイッチ)
NEC UNIVERGE IX2015 x5台
Firmware 8.37

NEC UNIVERGE IX2105 x4台

YAMAHA RTX810 x1台
YAMAHA RTX1210 x1台

上に書いた通り、次は1Gポート搭載のNW機器が欲しいです。笑
それと、やっぱりおさえておきたいCISCOとJUNIPER!笑

どなたか余ってる省電力のCISCOとjuniperください!!笑


久しぶりにみてみると、モバイルバッテリーもメモリもSSDもずいぶん安くなってるんですね!

皆さん既にやってると思いますが、 AmazonPrimeだとAmazon Music Unlimitedが月額780円でできるんですね!
最近知ってapple musicから乗り換えました。(200円ですが安い方がいいに越したことはないです笑)

下のRedmineの本は kindle unlimitedで無料で読めますのでお勧めです!(30日無料期間に読んで解約もアリだと思います。笑)



【tech】ix2015のIPアドレス設定と起動ログ



ヤフオクで中古で買ったNECの業務用ルータのIX2015の初期設定コンフィグ例です。
SW-HUBも兼ねている(HUBモジュールという?)モジュールへ初期設定として、IPアドレスを割り当てて、no shutするだけの簡単なconfigです。このコンフィグではSW-HUBとして
しか使えないのでハブ用途で使用の方はご参考下さい。

IX2015で使うコマンドもまとめておきたいな~

環境


NEC UNIVERGE IX2015
IPアドレス:192.168.100.100
サブネットマスク:255.255.255.0

###############
凡例
・説明
コマンド
→コマンドの省略系
###############



・コンフィグモードへ移行
enable-config
→en

・結果を全て表示
terminal length 0
→ter len 0

・現在の設定を確認
show running-config
→sh run

・インターフェースの設定モードへ移行
interface FastEthernet1/0.0
→int FastEthernet1/0.0

・IPアドレスの設定
ip address 192.168.100.100/24

・インターフェースの開放
no shutdown
→no shut

以下は起動からの操作ログです。(空行は省略しています)





NEC Diagnostic Software
Copyright (c) 2001-2008 NEC Infrontia All Rights Reserved.

%DIAG-INFO: Starting System POST(Power On Self Test)
DRAM TEST 1: Pass
DRAM TEST 2: Pass
NVRAM TEST: Pass
CPU TEST: Pass
PLD TEST: Pass
LAN1(FE0/0) TEST: Pass
LAN2(FE0/1) TEST: Pass
SECURITY TEST: Pass
VOLTAGE STATUS: 3.268V Pass
TEMPERATURE STATUS: +23.0degC Pass

NEC Bootstrap Software
Copyright (c) 2001-2008 NEC Infrontia All Rights Reserved.

%BOOT-INFO: No boot records found, attempting flash load.
%BOOT-INFO: Trying flash load, exec-image [ix2010-ms-8.3.49.ldc].
Loading: ######################################################## [OK]

NEC Diagnostic Software
Copyright (c) 2001-2008 NEC Infrontia All Rights Reserved.

%DIAG-INFO: Starting Interface Unit POST(Power On Self Test)

%DIAG-INFO: Interface unit is 4FESW-BRI
HUB(SW)1-4 TEST: Pass
BRI TEST: Pass

Starting at 0x20000

Configuring router subsystems (before IDB proc): done.
Constructing IDB(Interface Database): done.
Configuring router subsystems (after IDB proc): done.
Initializing router subsystems: done.
Starting router subsystems: done.

All router subsystems coming up.



NEC Portable Internetwork Core Operating System Software
Copyright Notices:
Copyright (c) 2001-2008 NEC Infrontia All Rights Reserved.
Copyright (c) 1985-1998 OpenROUTE Networks, Inc.
Copyright (c) 1984-1987, 1989 J. Noel Chiappa.
Router#
Router#enable-config
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#
Router(config)#
Router(config)#terminal length 0
Router(config)#
Router(config)#show running-config
Current configuration : 818 bytes

! NEC Portable Internetwork Core Operating System Software
! IX Series IX2010 (magellan-sec) Software, Version 8.3.49, RELEASE SOFTWARE
! Compiled Nov 25-Fri-2011 10:29:23 JST #1
! Current time Dec 20-Thu-2018 00:10:26 JST
!
!
timezone +09 00
!
!
device FastEthernet0/0
!
device FastEthernet0/1
!
device FastEthernet1/0
!
device BRI1/0
isdn switch-type hsd128k
!
interface FastEthernet0/0.0
no ip address
shutdown
!
interface FastEthernet0/1.0
no ip address
shutdown
!
interface FastEthernet1/0.0
no ip address
shutdown
!
interface BRI1/0.0
encapsulation ppp
no auto-connect
no ip address
shutdown
!
interface Loopback0.0
no ip address
!
interface Null0.0
no ip address
Router(config)#
Router(config)#
Router(config)# interface FastEthernet1/0.0
Router(config-FastEthernet1/0.0)#
Router(config-FastEthernet1/0.0)# ip address 192.168.100.100/24
Router(config-FastEthernet1/0.0)# no shut
Router(config-FastEthernet1/0.0)#
Router(config-FastEthernet1/0.0)# exit
Router(config)#
Router(config)#
Router(config)#show running-config
Current configuration : 837 bytes



! NEC Portable Internetwork Core Operating System Software
! IX Series IX2010 (magellan-sec) Software, Version 8.3.49, RELEASE SOFTWARE
! Compiled Nov 25-Fri-2011 10:29:23 JST #1
! Current time Dec 20-Thu-2018 00:12:29 JST
!
!
timezone +09 00
!
!
!
device FastEthernet0/0
!
device FastEthernet0/1
!
device FastEthernet1/0
!
device BRI1/0
isdn switch-type hsd128k
!
interface FastEthernet0/0.0
no ip address
shutdown
!
interface FastEthernet0/1.0
no ip address
shutdown
!
interface FastEthernet1/0.0
ip address 192.168.100.100/24
no shutdown
!
interface BRI1/0.0
encapsulation ppp
no auto-connect
no ip address
shutdown
!
interface Loopback0.0
no ip address
!
interface Null0.0
no ip address
Router(config)#
Router(config)#
Router(config)#



【tech】IX2015のfirmwareをバックアップしたメモ

※追記予定

ずいぶん前ですが、先輩に勧められて、ヤフオクでIX2015を買いました!
やっぱり実機を触った方がイメージがわいていいですね。
CentOS7でtftpサーバをつくってファームウェアやコンフィグのbackupをとる方法を調べたのでまずはfirmwareのbackupを取る手順をメモしておきます。

環境


tftpサーバ:tftp-server
サーバOS:CentOS7.5
IPアドレス:192.168.100.101
保存ディレクトリ:/ws/tftp

IX2015での作業
・configモードへ移行
Router#en

・firmwareのバックアップ
Router(config)# tftp put ix2010-ms-8.3.49.ldc 192.168.100.101:ix2010-ms-8.3.49.ldc

complateが出たら完了!

tftpサーバでの作業
・保存先ディレクトリへ移動
cd /ws/tftp

・ファイルの確認
ls
→「ix2010-ms-8.3.49.ldc」ファイルがあれば転送が出来ています!